PLEASE NOTE : These are the Community Forums (user-to-user), the Hauppauge team try to assist as time allows. Please use the email or telephone support if necessary as their tickets have priority!


+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1
    Join Date
    May 2012
    Posts
    9

    Default USB Live2 in Win7 64 bit Virtual XP Mode

    I am trying to use the Hauppauge USB-Live2 in Windows 7 XP Mode. This is a new Hauppauge USB-Live2 purchase. Originally I installed directly from the install CD (Version 2.4D – CD-WINTV7-V2.4D-SD-SB) but had problems with the Gaming mode. I used the HCWCLEAR in both Windows 7 and the XP Mode shell then downloaded and installed the “Install WinTV v7.x CD 2.5c” and this corrected the gaming mode issue. Therefore the USB-Live2 works in Windows 7 64-bit mode both with and without gaming mode.

    But when I try using it in XP Mode the WinTV 7 (both with and without Gaming Mode) display window is a blue screen (same as the XP Mode desktop background). When I select any option such as settings (configuration) and then close that window, the settings window stays displayed in the WinTV7 display window until I minimize the WinTV7 window and then restore it. I never have any composite video displayed even though I get the initial composite buffering message when WinTV7 is started. The Hauppauge USB Device is attached in XP Mode before starting the WinTV7 app.

    All latest Windows 7 updates have been applied. The PC is a Dell Precision T1500 Intel core I5 64bit CPU with 4 Gb.

    Any suggestions?

  2. #2
    Join Date
    Aug 2007
    Posts
    3,508

    Default Re: USB Live2 in Win7 64 bit Virtual XP Mode

    How do you mean in "XP Mode" ?
    Click here to see how to capture the right logs files for your problem for WinTV v7. You MUST attach logs files for us to effectively help you.

    http://www.hauppauge.co.uk/forum/showthread.php?22310

    This forum is User -> User support only. It is a supplement to Phone/E-mail Support. This forum is not monitored by Hauppauge Technical Support. If you require official Technical Support / Customer Service / Pre-Sales please CALL on 020 3405 1717 (UK) or if you are not located in the UK contact numbers are here:

    http://www.hauppauge.co.uk/site/contact/contact_us.html or e-mail: http://www.hauppauge.co.uk/site/supp...upcontact.html

    Keep up to date with Hauppauge news online

  3. #3
    Join Date
    May 2012
    Posts
    9

    Default Re: USB Live2 in Win7 64 bit Virtual XP Mode

    I am trying to use the USB-Live2 in a WIndows Virtual PC XP Mode shell. Attached are two logs: one for the running directly in Win7 and the other in the Virtual XP Mode PC. Aso attached is a screen print showing the XP Mode desktop with the WinTV 7 running.

    Thank you
    Attached Images
    Attached Files

  4. #4
    Join Date
    Aug 2007
    Posts
    3,508

    Default Re: USB Live2 in Win7 64 bit Virtual XP Mode

    This isn't something we support, I'm afraid, but it seems to be due to the video renderer.

    2012-05-14 09:24:26.981 [ERROR][1] Unexpected error in RefreshOSD(): System.AccessViolationException: Attempted to read or write protected memory. This is often an indication that other memory is corrupt.
    at VideoRendererOverlay.CompleteGraph(HWND__* hwnd)
    at NativeMMS.PlaybackLiveTV.PlayChannel(IntPtr hwndIntPtr, String filename, Channel channel)
    at TVServices.MultiMedia.xe0e66c09fb093862.xb08a488e0 44ec984(IntPtr x53ce467991507883)
    at WinTV7.Players.xf066bd4a96f8ec19.xa48c8c04bb25513b ()
    at WinTV7.Players.xf066bd4a96f8ec19.RefreshOSD()

    Have you tried the different Video Renderer options under Configuration -> General? You'll need to stop LiveTV after changing the value for it to apply.
    Click here to see how to capture the right logs files for your problem for WinTV v7. You MUST attach logs files for us to effectively help you.

    http://www.hauppauge.co.uk/forum/showthread.php?22310

    This forum is User -> User support only. It is a supplement to Phone/E-mail Support. This forum is not monitored by Hauppauge Technical Support. If you require official Technical Support / Customer Service / Pre-Sales please CALL on 020 3405 1717 (UK) or if you are not located in the UK contact numbers are here:

    http://www.hauppauge.co.uk/site/contact/contact_us.html or e-mail: http://www.hauppauge.co.uk/site/supp...upcontact.html

    Keep up to date with Hauppauge news online

  5. #5
    Join Date
    May 2012
    Posts
    9

    Default Re: USB Live2 in Win7 64 bit Virtual XP Mode

    Only "Overlay" video renderer mode is available in the settings. See attached bmp. Can I set a different video renderer in a cfg file or in the registry?
    Attached Images

  6. #6
    Join Date
    Aug 2007
    Posts
    3,508

    Default Re: USB Live2 in Win7 64 bit Virtual XP Mode

    If those renderers aren't available they are grey'd out. Why exactly are you using XP virtual mode?
    Click here to see how to capture the right logs files for your problem for WinTV v7. You MUST attach logs files for us to effectively help you.

    http://www.hauppauge.co.uk/forum/showthread.php?22310

    This forum is User -> User support only. It is a supplement to Phone/E-mail Support. This forum is not monitored by Hauppauge Technical Support. If you require official Technical Support / Customer Service / Pre-Sales please CALL on 020 3405 1717 (UK) or if you are not located in the UK contact numbers are here:

    http://www.hauppauge.co.uk/site/contact/contact_us.html or e-mail: http://www.hauppauge.co.uk/site/supp...upcontact.html

    Keep up to date with Hauppauge news online

  7. #7
    Join Date
    May 2012
    Posts
    9

    Default Re: USB Live2 in Win7 64 bit Virtual XP Mode

    We have several customers with an application that only runs in XP and will not or can not be updated to run under Win7. Due to the economy they are unwilling to spend the money on replacing the hardware and software with newer systems. The PC platforms that are running the older code is failing and can be replaced but with Win7 OS only. Using the virtual PC XP Mode runs everything that is needed except the analog video overly portion. This is temporary until the economy improves and they can budget for a new system.

    But does it really matter matter? We have a need for a analog video capture/overlay device to run in XP mode. If Hauppauge USB-Live2 device does not work in XP Mode are you aware of any other (Hauppauge or other manufacturers) USB analog video capture/overlay that work in XP Mode?

  8. #8
    Join Date
    Aug 2007
    Posts
    3,508

    Default Re: USB Live2 in Win7 64 bit Virtual XP Mode

    It sounds like the Video renderers aren't available in this mode. I will try and reproduce and see if there is any way around it, but it sounds like the Virtual OS just doesn't have these enabled. (but I would need to try it here to be 100% sure) - let me come back and see if I can suggest a work around
    Click here to see how to capture the right logs files for your problem for WinTV v7. You MUST attach logs files for us to effectively help you.

    http://www.hauppauge.co.uk/forum/showthread.php?22310

    This forum is User -> User support only. It is a supplement to Phone/E-mail Support. This forum is not monitored by Hauppauge Technical Support. If you require official Technical Support / Customer Service / Pre-Sales please CALL on 020 3405 1717 (UK) or if you are not located in the UK contact numbers are here:

    http://www.hauppauge.co.uk/site/contact/contact_us.html or e-mail: http://www.hauppauge.co.uk/site/supp...upcontact.html

    Keep up to date with Hauppauge news online

  9. #9
    Join Date
    Aug 2007
    Posts
    3,508

    Default Re: USB Live2 in Win7 64 bit Virtual XP Mode

    ok try this - this seemed to get it working for me:

    edit C:\Documents and Settings\All Users\Documents\WinTV\Settings.xml (in notepad)

    then find the line

    <VideoRenderer>EVR</VideoRenderer>

    and change it to:

    <VideoRenderer>Overlay</VideoRenderer>

    I'll see if I can detect "Virtual XP Mode" in the next release and deploy this automatically.
    Click here to see how to capture the right logs files for your problem for WinTV v7. You MUST attach logs files for us to effectively help you.

    http://www.hauppauge.co.uk/forum/showthread.php?22310

    This forum is User -> User support only. It is a supplement to Phone/E-mail Support. This forum is not monitored by Hauppauge Technical Support. If you require official Technical Support / Customer Service / Pre-Sales please CALL on 020 3405 1717 (UK) or if you are not located in the UK contact numbers are here:

    http://www.hauppauge.co.uk/site/contact/contact_us.html or e-mail: http://www.hauppauge.co.uk/site/supp...upcontact.html

    Keep up to date with Hauppauge news online

  10. #10
    Join Date
    May 2012
    Posts
    9

    Default Re: USB Live2 in Win7 64 bit Virtual XP Mode

    I have installed the WinTV 7 app in both the standard Win7 and the Virtual PC XP Mode shell. The VideoRenderer statement in the Virtual PC XP Mode Settings.xml is already set to "Overlay". In the Virtual PC XP Mode only the Overlay setting is available. I changed the XP Mode Setting.xml videorenderer statement from Overlay to EVR but did not work. It defaulted back to Overlay mode.

    The Settings.xml file for the Win7 version is set to "EVR" (all video renderer modes are selectable but EVR works best). In Win7, the USB-Live2 works fine in the EVR state even with Gaming mode on.

Similar Threads

  1. WinTV-NOVA-TD-Stick (958xx) - Diverisfy mode works - Dual tuner mode does not.
    By MarkieVee in forum 3rd Party Applications / Legacy Products (including MVP/wMVP)
    Replies: 8
    Last Post: 21-06-2013, 07:26 PM
  2. Hauppauge WinTV HVR-950Q on Windows 7 Virtual Machine, Ubuntu Host?
    By RubenMartinez in forum Pre Sales Advice
    Replies: 1
    Last Post: 31-07-2012, 10:52 AM
  3. Replies: 1
    Last Post: 07-04-2012, 10:07 PM
  4. USB live2 from USA
    By hartless in forum Pre Sales Advice
    Replies: 7
    Last Post: 26-10-2010, 12:13 PM
  5. Installer won't start and hangs on Virtual Machine
    By angelodelia in forum Fixed / FAQ
    Replies: 1
    Last Post: 25-05-2010, 03:51 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts